Australian Business Directory

Aussiesrus Australia

Bing Search Engine Fix for Australian Joomla 2.5 - 3.1 Users

Bing will set your region to Great Britain using a standard Joomla 2.5.x - 3.1.x install

As you may or may not be aware the standard Joomla installation comes with the English (GB) Language pack. As Australia uses the "English language set" this poses no issue in general use. However the search engine Bing will set your region to gb which does create an issue for web masters that wish to be set in the Australian region.

 

How to check why Bing has determined my region is Great Britain

You can easily check your website region and language setting by going to your homepage and right clicking on the homepage and selecting "view source". This will open a page containing your source code which search engines will see. If you see this, as per the image below, then you are set for the gb region.


en-gb xtml code

Your lang region setting as en-gb means that Bing will have your website located in the Great Britain region. This is not optimal if you are an Australian website hosted in Australia and targetting the Australian market.

 

How to solve the issue

Aussiesrus have re-written the standard EN-GB Language pack as a Joomla! install language package. As Australia uses the "English language set" the language contained within the files still use the normal en-gb text. The file names have been modified as necessary and install xml files modified to set your region as per the image below.

 en-au region settings

 

2.5.x File download

 You can download the Joomla! Accredited 2.5.x file here:

25xEnglish (Australian) Joomla Translation 2.5.x Pack

The 2.5.x native pack is ONLY for 2.5.x users.  

 

3.1.x File download

You can download the Joomla! Accredited 3.1.x file here:

compat 30 English (Australian) Joomla Translation 3.1.x Pack 

The 3.1.x native pack is ONLY for 3.1.x users.

 

Installation for 2.5.X Users

Tested using 2.5.11 successfully.

To install:

1. Download zip file en-AU_joomla_lang_full_2.5.10v1.zip.
2. Log into joomla admin backend
3. Select Extensions Manager
4. Upload zip file
5. Go to Extensions/Language manager
6. Set English(Australia) as default for both Site and Administrator

You're done!

*** One click admin backend update versions now available for versions 2.5v ***

Packs which are named with a version number IE: v1-v2-v3 etc now conform with the new Joomla! auto-update system for one click admin backend updates.

* Do not remove or delete the English (United Kingdom) Language pack. This will be required in case you decide to uninstall the English (Australian) Joomla Translation Pack.

 

Installation for 3.1.X Users

Tested using 3.1.1 successfully. 3.1.0v1 language pack is 3.1.1 compatible

To install:

1. Download zip file en-AU_joomla_lang_full_3.1.0v1.zip.
2. Log into joomla admin backend
3. Select Extensions Manager
4. Upload zip file
5. Go to Extensions/Language manager
6. Set English(Australia) as default for both Site and Administrator

You're done!

*** One click admin backend update versions now available for versions 3.0v ***

Packs which are named with a version number IE: v1-v2-v3 etc now conform with the new Joomla! auto-update system for one click admin backend updates.

* Do not remove or delete the English (United Kingdom) Language pack. This will be required in case you decide to uninstall the English (Australian) Joomla Translation Pack.

 

 

Joomla! 1.5.x - 1.6.x - 1.7.x is no longer supported.